AWS instability and service disruption

Incident Report for Ready Education

Resolved

Campus Cloud and Campus App should be stable now that AWS has resolved their issue.
Posted Oct 21, 2025 - 08:53 EDT

Monitoring

There is currently a wide-spread issue with AWS (Amazon Web Services) that may have caused and may continue to cause intermittent issues on the Ready Education platform. Our team has been actively monitoring the situation. Unfortunately, the resolution of this service interruption is completely dependent on AWS restoring their core services.

Thank you for your patience and partnership as we navigate this external challenge.
Posted Oct 20, 2025 - 12:15 EDT